Back to overview
Degraded

Issues connecting to Stripe

Jan 22 at 04:10pm EET
Affected services
payment

Resolved
Jan 22 at 04:12pm EET

Issue resolved. Billing, if affected, will be resumed automatically

Created
Jan 22 at 04:10pm EET

We are experiencing network issues connecting to Stripe API. This may affect payment for some customers.